IPSEC Site-to-SITE VPN – ASA and CheckPoint R75.40 Part 2/3

IPSEC Site-to-SITE VPN – ASA and CheckPoint R75.40 Part 1/3

CCNA VOICE – Basic VoIP – CME within LAN Part 2/2

VoIP with Frame Relay Cloud Part 3/3

*************************
CONFIGURE BRANCH1 ROUTER AS CME/DHCP
*************************************
!
clock timezone CO -5
!
!
service dhcp
!
ip dhcp excluded-address 192.168.10.1 192.168.10.10
ip dhcp excluded-address 192.168.20.1 192.168.20.10
!
ip dhcp pool VOICE_VLAN
network 192.168.20.0 255.255.255.0
default-router 192.168.20.1
option 150 ip 192.168.20.1
dns-server 8.8.8.8 8.8.4.4
!
ip dhcp pool DATA_VLAN
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
option 150 ip 192.168.10.1
dns-server 8.8.8.8 8.8.4.4
!
!
telephony-service
no auto-reg-ephone
max-ephones 10
max-dn 20
ip source-address 192.168.10.1 port 2000 secondary 192.168.20.1
system message VOIP_BRANCH1
time-zone 11
time-format 24
max-conferences 8 gain -6
web admin system name administrator secret 5 $1$7DWn$rvUTJtwkW21Zy/LU4h6be1
dn-webedit
time-webedit
!
!
!
ephone-dn 1 dual-line
number 1111
label Jayden Herrera (1111)
description SOFTPHONE_B1
!
!
ephone 1
device-security-mode none
mac-address 0800.2771.A18A
username “Jayden” password Jayden12345
type CIPC
button 1:1
pin 12345
!
end
!
clock set 19:46:22 17 May 2014
!
!
configure terminal
!
telephony-service
no create cnf-files
create cnf-files
!PC1
*************************
CONFIGURE BRANCH2 ROUTER AS CME/DHCP
*************************************
!
clock timezone CO -5
!

!
service dhcp
!
ip dhcp excluded-address 192.168.110.1 192.168.110.10
ip dhcp excluded-address 192.168.120.1 192.168.120.10
!
ip dhcp pool VOICE_VLAN
network 192.168.120.0 255.255.255.0
default-router 192.168.120.1
option 150 ip 192.168.120.1
dns-server 8.8.8.8 8.8.4.4
!
ip dhcp pool DATA_VLAN
network 192.168.110.0 255.255.255.0
default-router 192.168.110.1
option 150 ip 192.168.110.1
dns-server 8.8.8.8 8.8.4.4
!
!
telephony-service
no auto-reg-ephone
max-ephones 10
max-dn 20
ip source-address 192.168.110.1 port 2000 secondary 192.168.120.1
system message VOIP_BRANCH2
time-zone 11
time-format 24
max-conferences 8 gain -6
web admin system name administrator secret 5 $1$7DWn$rvUTJtwkW21Zy/LU4h6be1
dn-webedit
time-webedit
!
!
!
ephone-dn 1 dual-line
number 2222
label Jh0n Herrera (2222)
description SOFTPHONE_B2
!
!
ephone 1
device-security-mode none
mac-address 0800.27a1.a04d
username “Jh0n” password JJh0n12345
type CIPC
button 1:1
pin 12345
!
end
!
clock set 19:46:22 17 May 2014
!
!
configure terminal
!
telephony-service
no create cnf-files
create cnf-files
!
!
PC2
!
*************************
CONFIGURE BRANCH3 ROUTER AS CME/DHCP
*************************************
!
clock timezone CO -5
!

!
service dhcp
!
ip dhcp excluded-address 192.168.210.1 192.168.210.10
ip dhcp excluded-address 192.168.220.1 192.168.220.10
!
ip dhcp pool VOICE_VLAN
network 192.168.220.0 255.255.255.0
default-router 192.168.220.1
option 150 ip 192.168.220.1
dns-server 8.8.8.8 8.8.4.4
!
ip dhcp pool DATA_VLAN
network 192.168.210.0 255.255.255.0
default-router 192.168.210.1
option 150 ip 192.168.210.1
dns-server 8.8.8.8 8.8.4.4
!
!
telephony-service
no auto-reg-ephone
max-ephones 10
max-dn 20
ip source-address 192.168.210.1 port 2000 secondary 192.168.220.1
system message VOIP_BRANCH3
time-zone 11
time-format 24
max-conferences 8 gain -6
web admin system name administrator secret 5 $1$7DWn$rvUTJtwkW21Zy/LU4h6be1
dn-webedit
time-webedit
!
!
!
ephone-dn 1 dual-line
number 3333
label Herrera’s Family (3333)
description SOFTPHONE_B3
!
!
ephone 1
device-security-mode none
mac-address 0800.27E8.F015
username “Jh0n” password JJh0n12345
type CIPC
button 1:1
pin 12345
!
end
!
clock set 19:46:22 17 May 2014
!
!
configure terminal
!
telephony-service
no create cnf-files
create cnf-files
!
!

PC3
!
****************************
ENRUTAMIENTO VOIP con DIAL-PEER BRANCH1 ROUTER
***********************************
!
dial-peer voice 1 voip
destination-pattern 2222
session target ipv4:10.1.1.2
dial-peer voice 2 voip
destination-pattern 3333
session target ipv4:10.1.1.3
!
****************************
ENRUTAMIENTO VOIP con DIAL-PEER BRANCH2 ROUTER
***********************************
!
dial-peer voice 1 voip
destination-pattern 1111
session target ipv4:10.1.1.1
dial-peer voice 2 voip
destination-pattern 3333
session target ipv4:10.1.1.1
!
!
****************************
ENRUTAMIENTO VOIP con DIAL-PEER BRANCH3 ROUTER
***********************************
!
dial-peer voice 1 voip
destination-pattern 1111
session target ipv4:10.1.1.1
dial-peer voice 2 voip
destination-pattern 2222
session target ipv4:10.1.1.1
!
!
****************************
HABILITAR REENVIO DE LLAMADAS EN BRANCH1 ROUTER
***********************************
!
voice service voip
supplementary-service h450.12
allow-connections h323 to h323
telephony-service
call-forward pattern .T
!
!
!
!
BRANCH1#show dial-peer voice summary
dial-peer hunt 0
AD PRE PASS OUT
TAG TYPE MIN OPER PREFIX DEST-PATTERN FER THRU SESS-TARGET STAT PORT
20002 pots up up 1111$ 0 50/0/1
1 voip up up 2222 0 syst ipv4:10.1.1.2
2 voip up up 3333 0 syst ipv4:10.1.1.3
BRANCH1#
!
!!!!
!
BRANCH2#show dial-peer voice summary
dial-peer hunt 0
AD PRE PASS OUT
TAG TYPE MIN OPER PREFIX DEST-PATTERN FER THRU SESS-TARGET STAT PORT
20001 pots up up 2222$ 0 50/0/1
1 voip up up 1111 0 syst ipv4:10.1.1.1
2 voip up up 3333 0 syst ipv4:10.1.1.1
BRANCH2#
!
!!!!
!
BRANCH3#show dial-peer voice summary
dial-peer hunt 0
AD PRE PASS OUT
TAG TYPE MIN OPER PREFIX DEST-PATTERN FER THRU SESS-TARGET STAT PORT
20001 pots up up 3333$ 0 50/0/1
1 voip up up 1111 0 syst ipv4:10.1.1.1
2 voip up up 2222 0 syst ipv4:10.1.1.1
BRANCH3#
!!!!
!!
!

VoIP with Frame Relay Cloud Part 2/3

**** BRANCH1 CONFIG ****
**********************************
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
no cdp enable
!
interface FastEthernet0/1.10
description **** VLAN 10 DATA ****
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet0/1.20
description **** VLAN 20 VOICE ****
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
!
interface FastEthernet0/1.30
description **** VLAN 30 MANAGEMENT ****
encapsulation dot1Q 30
ip address 192.168.30.1 255.255.255.0
!
interface FastEthernet0/1.40
encapsulation dot1Q 40 native
!
ip route 192.168.110.0 255.255.255.0 10.1.1.2 name BRANCH2_DATA
ip route 192.168.120.0 255.255.255.0 10.1.1.2 name BRANCH2_VOICE
ip route 192.168.210.0 255.255.255.0 10.1.1.3 name BRANCH3_DATA
ip route 192.168.220.0 255.255.255.0 10.1.1.3 name BRANCH3_VOICE
**** SWCORE1 CONFIG ****
**********************************
!
vlan database
vlan 10 name DATA
vlan 20 name VOICE
vlan 30 name MANAGEMENT
vlan 40 name NATIVE
apply
!
!
interface FastEthernet1/0
description **** CONNECTED to BRANCH1 ****
switchport mode trunk
no cdp enable
!
interface FastEthernet1/1
switchport access vlan 10
switchport voice vlan 20
spanning-tree portfast
!
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan30
description **** MANAGEMENT INTERFACE ****
ip address 192.168.30.2 255.255.255.0
!
ip default-gateway 192.168.30.1
!
!
line con 0
exec-timeout 0 0
logging synchronous
!
!
!
**** BRANCH2 CONFIG ****
**********************************
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
no cdp enable
no shutdown
!
interface FastEthernet0/1.10
description **** VLAN 10 DATA ****
encapsulation dot1Q 10
ip address 192.168.110.1 255.255.255.0
!
interface FastEthernet0/1.20
description **** VLAN 20 VOICE ****
encapsulation dot1Q 20
ip address 192.168.120.1 255.255.255.0
!
interface FastEthernet0/1.30
description **** VLAN 30 MANAGEMENT ****
encapsulation dot1Q 30
ip address 192.168.130.1 255.255.255.0
!
interface FastEthernet0/1.40
encapsulation dot1Q 40 native
!
ip route 0.0.0.0 0.0.0.0 10.1.1.1 name DEFAULT_ROUTE

**** SWCORE2 CONFIG ****
**********************************
!
vlan database
vlan 10 name DATA
vlan 20 name VOICE
vlan 30 name MANAGEMENT
vlan 40 name NATIVE
apply
!
!
interface FastEthernet1/0
description **** CONNECTED to BRANCH2 ****
switchport mode trunk
no cdp enable
!
interface FastEthernet1/1
switchport access vlan 10
switchport voice vlan 20
spanning-tree portfast
!
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan30
description **** MANAGEMENT INTERFACE ****
ip address 192.168.130.2 255.255.255.0
!
ip default-gateway 192.168.130.1
!
!
line con 0
exec-timeout 0 0
logging synchronous
!
!
!
**** BRANCH3 CONFIG ****
**********************************
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
no cdp enable
no shutdown
!
interface FastEthernet0/1.10
description **** VLAN 10 DATA ****
encapsulation dot1Q 10
ip address 192.168.210.1 255.255.255.0
!
interface FastEthernet0/1.20
description **** VLAN 20 VOICE ****
encapsulation dot1Q 20
ip address 192.168.220.1 255.255.255.0
!
interface FastEthernet0/1.30
description **** VLAN 30 MANAGEMENT ****
encapsulation dot1Q 30
ip address 192.168.230.1 255.255.255.0
!
interface FastEthernet0/1.40
encapsulation dot1Q 40 native
!
ip route 0.0.0.0 0.0.0.0 10.1.1.1 name DEFAULT_ROUTE

**** SWCORE3 CONFIG ****
**********************************
!
vlan database
vlan 10 name DATA
vlan 20 name VOICE
vlan 30 name MANAGEMENT
vlan 40 name NATIVE
apply
!
!
interface FastEthernet1/0
description **** CONNECTED to BRANCH3 ****
switchport mode trunk
no cdp enable
!
interface FastEthernet1/1
switchport access vlan 10
switchport voice vlan 20
spanning-tree portfast
!
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan30
description **** MANAGEMENT INTERFACE ****
ip address 192.168.230.2 255.255.255.0
!
ip default-gateway 192.168.230.1
!
!
line con 0
exec-timeout 0 0
logging synchronous
!
!
!
BRANCH1#ping ip 192.168.110.1 source fa0/1.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.110.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.10.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/82/120 ms
BRANCH1#ping ip 192.168.120.1 source fa0/1.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.120.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.10.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/91/152 ms
BRANCH1#ping ip 192.168.210.1 source fa0/1.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.210.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.10.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/84/144 ms
BRANCH1#ping ip 192.168.220.1 source fa0/1.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.220.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.10.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/76/112 ms
BRANCH1#ping ip 192.168.110.1 source fa0/1.20

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.110.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.20.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/82/136 ms
BRANCH1#ping ip 192.168.120.1 source fa0/1.20

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.120.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.20.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/80/104 ms
BRANCH1#ping ip 192.168.210.1 source fa0/1.20

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.210.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.20.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/73/116 ms
BRANCH1#ping ip 192.168.220.1 source fa0/1.20

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.220.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.20.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/70/120 ms
BRANCH1#

VoIP with Frame Relay Cloud Part 1/3

Hola a todos,

En este post veremos como realizar la configuracion basica de la nube Frame Relay y comunicar varios sitios con telefonia Voz IP en GNS3.

Topologia de red:


************** Configuracion Nube Frame Relay *******************
**** Frame Relay SWITCH FRSW1 ****
**********************************
!
hostname FRSW1
!
frame-relay switching
!
interface Serial1/0
description **** CONNECTED to BRANCH1 ****
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay intf-type dce
clock rate 64000
frame-relay route 102 interface Serial1/1 101
frame-relay route 103 interface Serial1/2 321
!
interface Serial1/1
description **** CONNECTED to FRSW3_S1/0 ****
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
frame-relay intf-type nni
frame-relay route 101 interface Serial1/0 102
!
interface Serial1/2
description **** CONNECTED to FRSW2_S1/0 ****
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay intf-type nni
frame-relay route 321 interface Serial1/0 103
!
!
line con 0
exec-timeout 0 0
logging synchronous
!
!
!
!
**** Frame Relay SWITCH FRSW2 ****
**********************************
!
hostname FRSW2
!
frame-relay switching
!
interface Serial1/0
description **** CONNECTED to FRSW1_S1/2 ****
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay intf-type nni
frame-relay route 321 interface Serial1/1 102
!
interface Serial1/1
description **** CONNECTED to FRSW4_S1/1 ****
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay intf-type nni
frame-relay route 102 interface Serial1/0 321
!
!
line con 0
exec-timeout 0 0
logging synchronous
!
!
!
**** Frame Relay SWITCH FRSW3 ****
**********************************
!
hostname FRSW3
!
frame-relay switching
!
interface Serial1/0
description **** CONNECTED to FRSW1_S1/1 ****
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay intf-type nni
frame-relay route 101 interface Serial1/2 111
!
interface Serial1/1
no ip address
serial restart-delay 0
!
interface Serial1/2
description **** CONNECTED to FRSW4_S1/3 ****
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay intf-type nni
frame-relay route 111 interface Serial1/0 101
!
!
line con 0
exec-timeout 0 0
logging synchronous
!
!
!
**** Frame Relay SWITCH FRSW4 ****
**********************************
!
hostname FRSW4
!
frame-relay switching
!
interface Serial1/0
description **** CONNECTED TO BRANCH2_S1/0 ****
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
frame-relay intf-type dce
frame-relay route 201 interface Serial1/3 111
!
interface Serial1/1
no ip address
serial restart-delay 0
!
interface Serial1/2
description **** CONNECTED to FRSW2_S1/1 ****
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay intf-type nni
frame-relay route 102 interface Serial2/0 301
!
interface Serial1/3
description **** CONNECTED to FRSW3_S1/2 ****
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay intf-type nni
frame-relay route 111 interface Serial1/0 201
!
interface Serial2/0
description **** CONNECTED to BRANCH3_S1/0 ****
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
frame-relay intf-type dce
frame-relay route 301 interface Serial1/2 102
!
!
line con 0
exec-timeout 0 0
logging synchronous
!
!
!
**** BRANCH1 Frame Relay Config ****
**********************************
!
interface Serial1/0
description **** CONNECTED to FRSW1_S1/0 ****
ip address 10.1.1.1 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
!
**** BRANCH2 Frame Relay Config ****
**********************************
!
interface Serial1/0
description **** CONNECTED to FRSW4_S1/0 ****
ip address 10.1.1.2 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
!
**** BRANCH3 Frame Relay Config ****
**********************************
!
interface Serial1/0
description **** CONNECTED to FRSW1_S1/0 ****
ip address 10.1.1.3 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
!
!
!
BRANCH1#show frame-relay map
Serial1/0 (up): ip 10.1.1.2 dlci 102(0×66,0×1860), dynamic,
broadcast,, status defined, active
Serial1/0 (up): ip 10.1.1.3 dlci 103(0×67,0×1870), dynamic,
broadcast,, status defined, active
BRANCH1#
!
!
BRANCH2#show frame-relay map
Serial1/0 (up): ip 10.1.1.1 dlci 201(0xC9,0×3090), dynamic,
broadcast,, status defined, active
BRANCH2#
!
!
BRANCH3#show frame-relay map
Serial1/0 (up): ip 10.1.1.1 dlci 301(0x12D,0x48D0), dynamic,
broadcast,, status defined, active
BRANCH3#
!
!
 

CCNA Voice – Basic VoIP CME – within LAN Part 1/2

Chapter 5 – CCNA VOICE

• Ensuring the Foundation: This section explores the configuration foundation that must be in place to allow for a working IP telephony environment.
• Ephone and Ephone-DN—The Keys to Ringing Phones: Configuring Cisco IP Phones and directory numbers from the CLI is the most flexible method you can use to manage your end devices. This section walks through the ephone (IP phone) and ephone-dn (directory number) setup.
• Adding Directory Numbers, Phones, and Users with CCP: For the not-so-command-line-at-heart, Cisco enables you to configure the same telephony components using a point-and-click GUI. This section walks through the configuration of the core telephony components using CCP.
!
During the IP phone boot process, the IP phone contacts the TFTP server to download its configuration files. Until this point, you might wonder, “Where is this TFTP server? And what is in that configuration file?” I’m glad you asked. The TFTP server is what it has always been: a simple file store that serves files to unauthenticated clients on demand. Although you can install and configure a TFTP server on virtually any device, typically the Cisco router (in the case of CME) or the CUCM Publisher server handles the role of the TFTP server.
The TFTP server plays the role of “file server” in the IP telephony network. The IP phones download their configuration and firmware files from this server. The CME router generates these configuration files as you work through the initial configuration. For example, if you specify a new firmware load for a Cisco IP Phone to use, the CME router would modify a configuration file in flash (or an external TFTP server, if that’s what you chose to use) to list the new firmware image. The next time the phone reboots, it receives the new configuration file, realizes its firmware is out of date, and contacts the TFTP server to download and apply the new firmware image.
If you have not entered any individual phone configurations, the only configuration file sent to the Cisco IP Phones is the XMLDefault.cnf.xml file. This file contains the IP address and port number used to connect to the call processing server (the CME router, in our case) and the names of the firmware file the IP phone should use. After the IP phone has this configuration file, it downloads the necessary firmware and contacts the CME router.
!
NOTE:
::::::
In CME 4.0 and later, configuration and firmware files can be stored on an external TFTP server using the command cnf-file location tftp://<ip address of TFTP server> from telephony service configuration mode.
!
The alias syntax that follows the tftp-server command enables the firmware file to be requested simply by asking for the aliased filename. This is necessary in the newer CME versions, which organize the firmware files into subdirectories. The Cisco IP Phones do not know the full path to the firmware file; they ask only for the firmware filename.
!
• IP Source Address
• Max-DN
• Max-Ephones
Although you can configure many additional features, these three are necessary to get the phone system up and running.
!
The max-ephones parameter configures the maximum number of IP phones the router will support, whereas the max-dn parameter specifies the maximum number of directory numbers. The ip source-address command enables the router to know which IP address will receive registration requests from the IP phones.
!
NOTE:
:::::
The max-ephones and max-dn parameters directly affect how much memory the router reserves to support the CME service. Setting the value much higher than you actually need might reserve excessive resources on your router and impact other network services. In addition, the max-ephones parameter should not be any higher than the number of feature licenses you have purchased for your CME system.
!
Understanding and Configuring Ephone-DNs
An ephone-dn in its simplest form is just a directory number that can be assigned to one or more buttons on one or more Cisco IP Phones. You can configure each ephone-dn you create as either a single- or dual-line mode ephone-dn. Here’s the difference:
!!!!!
• Single-line ephone-dn: In single-line mode, the ephone-dn is able to make or receive only one call at a time. If a call arrives on an ephone-dn where there is already an active call, the caller receives a busy signal.
• Dual-line ephone-dn: In dual-line mode, the ephone-dn is able to handle two simultaneous calls. This is useful for supporting features like call waiting, conference calling, and consultative transfers.
In most network environments, dual-line configurations are useful for user IP phones, whereas single-line configurations are useful for network functions (such as intercom or paging). Example 5-5 configures two ephone-dns: the first as a single-line and the second as a dual-line.
!
That’s all there is to it! Notice the range of ephone-dn tags from the context-sensitive help is 1–150. This tag is a logical number, which is used when assigning the ephone-dn to an ephone. You can choose any ephone-dn tag from the range when creating the ephone-dn as long as the total number of ephone-dns does not exceed the number specified using the max-dn command.
!
The number syntax (which is used to assign a directory number to an ephone-dn) also supports a secondary number value. For example, you can enter the following:
CME_Voice(config)#ephone-dn 2 dual-line
CME_Voice(config-ephone-dn)#number 1001 secondary 4805551001
!!!!
This enables the ephone-dn to answer for multiple phone numbers. This can be used if you want an internal extension to be reachable if someone on the internal network dialed a four-digit extension or the full Public Switched Telephone Network (PSTN) Direct Inward Dial (DID) number.
!
Note
DID is a feature supported by PSTN carriers that enables internal extensions to be reached by PSTN callers directly without the need to route calls through a receptionist.
!
After you enter the command ephone <tag>, the CME router moves you into ephone configuration mode. Every command you enter after this directly affects the Cisco IP Phone matched to this ephone.
After initially creating the ephone, you need to logically link it to the physical IP phone it represents. The CME router uses the MAC address of a Cisco IP Phone for this purpose.
!
Tip
If you ever see a phone’s status shown as DECEASED in the show ephone output, the CME router has lost connectivity with the IP phone through a TCP keepalive failure. The UNREGISTERED status indicates the CME router closed the connection to the IP phone in a normal manner.
!
Linking ephones and ephone-dns is probably the most confusing section of the CME configuration because there are so many options. You can assign ephone-dns by using the button command from ephone configuration mode. The basic syntax of this command is as follows:
button <physical button> <separator> <ephone-dn>
!
!!!!!!!!!!!
• IP phone 1 (normal employee)
• Line 1: Directory number 1010
• Line 2: Directory number 1015
• IP phone 2 (normal employee)
• Line 1: Directory number 1011
• Line 2: Directory number 1015
• IP phone 3 (receptionist)
• Line 1: Directory number 1012
• Line 2: Directory number 1013
• Line 3: Directory number 1015
The company wants the employees to share directory number 1015 so any of them can answer incoming calls. The configuration in Example 5-13 accomplishes this scenario.
!
This simple configuration window also contains the information CME uses to build a local directory of users. After you add these users to CME, the users of the VoIP system will be able to press the directories button on their IP phone, navigate to Local Directory, and search the database of users contained in CME.
!

Seguir

Recibe cada nueva publicación en tu buzón de correo electrónico.